Apple rejects every binary created with Cocos Creator 1.6.2 due to bad code signing

Apple rejects every binary created with Cocos Creator 1.6.2 due to bad code signing
0.0 0

#1

Every Cocos creator Project that I export with jsb link will be rejected by iTunes connect. Uploading has no errors but 2 minutes later I receive an email saying “Invalid Signature - A sealed resource is missing or invalid. The file at path [xxxxxxx.app/binaryname] is not properly signed. Make sure you have signed your application with a distribution certificate, not an ad hoc certificate or a development certificate.” Does anyone have a hint where the problem could be. I did a lot of checks verifying code signing. All tests succeeded entitlement checking etc.

I’m really frustrated by this


#2

Well I suppose you could simply export it in mobile web and make a build using apache cordova. Well I said simply but its actually hard work. But I bet it will be worth it.


#3

Let me ask our engineering team to take a look at this.

@jare can you help?


#4

Make sure you use XCode to sign your project. And published as a ipa, not app, please.


#5

I’m using XCode 9. Did a full compile in XCode using Archive method and tried uploading from Organizer window. Uploading worked well and said everything is fine. 2 Minutes later my app got rejected. One Thing I recognized was that an empty project (no assets except a scene) made it all the way through to a valid binary.
@jare what do you mean by publish as ipa and publish as app?


#6

Are you using binary template?


#7

no jsb-link


#8

It should be the problem of your certificate.


#9

That was my first thought but I don’t understand why I can sign and upload a empty project successfully using same certificate, Provision Profile and bundle id.


#10

Sorry, I don’t know.


#11

Bad signing relates to the certificates itself, not cocos creator. You should check errors from Apple. I got errors for missing AppIcon assets. Cocos creator generates xcode template which doesn’t have that configuration.

For current version (1.6.2), try to fix it and god bless you!


#12

Finally I found the Issue! I had Assets named with an space or an ä. Which seems to fail at apples server. Renaming these files solved the signing problem.