Animation behavior changed after upgrading to v3.17 from v3.10

Animation behavior changed after upgrading to v3.17 from v3.10
0
#1

Hi

After upgrading from v3.10 to v3.17, I found there is an animation behavior changed.

If I set an action with duration 5s, and at the same time, some long-running code occupied main-thread for 2s,

in v3.10, the whole 5s animation was played from the beginning after the 2s, ended at the 7th sec.
0 1 2 3 4 5 6 7
|||||||s-----------e

in v3.17, the animation was only played the remaining 3s, ended at the 5th sec.
0 1 2 3 4 5 6 7
|||||||s------e

I would not say it’s not good for this change, but for my game it may cause bad UX.
Any one knows this change is from what version? Or it’s related to what files?

Thanks,
Jo

#2

This is probably fixed with this open PR.

Noted discussion in this Issue:

1 Like
#3

Thanks for the info.
The issue seems to be introduced from v3.16.
Do you recommend to merge this PR or fall back to v3.15?

#4

tl;dr - I’d probably try merging PR into your current 3.17 build/source and see if it works without too much effort.


Depends on whether you need anything new in 3.17 (features or fixes) or whether you want to keep up-to-date as 3.18+ come out.

If you’re near release and 3.15 is working for you without issues on real devices and you’re able to revert back to it then I would recommend “freezing” your cocos2d version and source and don’t update until after your first/next release + bug fixes.

If your release date is 6+ months from now then I’d recommend going to 3.17+ and staying on latest (until closer to release).

#5

Thanks for your detail explanation.

The main reason for upgrading is for Google play 64-bit support.
We still have time to wait for v3.18. Hope it’s not far from now. :slight_smile:

#6

I merged #19135 to v3.17.1, but still got the same weird animation behavior.

#7

Hi

I tried 3.17.1 which merged the pull request #18898 you mentioned.
However, the animation behavior is still the same.

Should I manually merge #19135 to fix this issue?

Any suggestion would be helpful.

Thanks,
Jo