Android Studio emulator problem

Android Studio emulator problem
0.0 0

#21

Our entire 4th year class are having emulator issues. Our lecturer is still having issues after months. I use a real phone, doesn’t have any issues. Best advice is save yourself the suffering and just use a android phone attached to i presume your android studio. Works with no issues for me and everyone in class always


#22

I can’t see GLES 3 option there. Try to update emulator using sdk manager then check it again.


#23


This config works for me.


#24

@hgokturk are you using Android Studio 3.0.1 ?
Where’s located “Extended controls” window? Please tell me step by step.
Remember, I’m using high Sierra, not windows.


#25

Yes it’s Android Studio 3. Settings of emulator.


#26

I just want to report that I’m seeing the same issue when running cpptests under the emulator.

Initially just black screen with the 0x501 errors. After I added mediump to COCOS2D_SHADER_UNIFORMS in CCGLProgram.cpp following domp’s advice, the tests actually run, however the same errors are still printed to the Gradle Console.

High Sierra 10.13.3
Android Studio 3.0.1
cocos2d-x-3.16

x86 target


#27

Android emulator is very problematic lately.


#28

I still didn’t resolve the problem. If anyone find a solution, post here :wink:


#29

Our lecturer recently fixed it for our class. He was trying for months. I can share what he told us do, assuming you have all other things working.
He added couple lines in this file where ever it is in the cocos library and it sorts issues

Something got do wth opengl or android emulator rendering thing or something GLES I think

CCGLProgram.cpp (35.5 KB)

I think this is the file that he added a couple lines code in somewhere and then emulator worked . no idea where it goes. i can ask him if anyone wants me to in email. Let me know