Android Studio 2.2

Android Studio 2.2
0.0 0

#21

How’s the progress :smiley: ?


#22

@piotrros You can follow the PR, all progress is there.


#23

Nice. Fingers crossed!


#24

Has anyone managed to hit the C++ breakpoints yet? :blush:


#25

I have not gotten breakpoints to hit yet, however if I pause the cocos2dx app running and go into the LLDB pane in the debugger window I can type:

p *Director::getInstance()

(which is gdb debugger-speak for “print out the full description of the Director::getInstance() object”)

and it outputs a fully-valid description with names of all the fields and values correct. So the Debugger “works” however I think there is just some disconnect between the Android Studio front end and the lldbserver in setting a breakpoint.


#26

What did you mean?

I can also hit the breakpoint too.


#27

Ah ok. I was using the “native” debugger (in “Edit Configurations…”, and no breakpoints would hit.

But now I’ve upgraded my Nexus 6 to the Android N preview 3, and selected “hybrid” debugger and my Java breakpoints work, but still not C++


#28

@Ajas Did you apply the PR i pasted above?


#29

What mean PR?:slight_smile:


#30

Pull Request


#31

The pull request: https://github.com/cocos2d/cocos2d-x/pull/15676


#32

@zhangxm, did you do anything outside of the PR conversation to get the C++ break point to hit?

I managed to build & deploy fine to Nexus 9 (Android N). Only the Java break points are working for me.
Btw, I’m doing this on Windows 8.


#33

I think you should select xxx-native target if you want to debug native codes.


#34

I had tried that too … but no luck.

Thanks anyway.


#35

What’s your error? I think you can report it in the PR.


#36

@zhangxm I’m still using CocosStudio and I’m having problems compiling my project with cmake.
I’m getting the same error in every class that uses a cocosstudio specific class:

vtable for BuyWidget: error: undefined reference to 'non-virtual thunk to cocos2d::ui::Layout::createLayoutManager()'

Do you have any ideas? It seems that every folder inside cocos has its own CMakeList.txt while the ones in editor-support don’t have it.


#37

@TheCodez How did you compile the codes? Have you applied the patch?


#38

@zhangxm yes, im using Android Studio 2.2 and have applied the pr. I can compile a new project but i can’t compile one that uses CocoStudio.


#39

What did you mean? Did you mean the tests shift in cocos2d-x? It is because that PR didn’t modify tests projects.


#40

We’ve been building under Android Studio 1.5 calling NDK_BUILD from gradle. Not sure how good it is to use cmake under xcode.