Android app built with minSdkVersion 19 does not launch on Android 4.4.2 (api 19)

Android app built with minSdkVersion 19 does not launch on Android 4.4.2 (api 19)
0

Hi folks.
My game is building and running successfully with target api level 19 on my Android 4.4.2 device.
I’ve changed target api level to 28 according to Google Play’s requirements. App builds successfully but does not launch on my phone even minSdkVersion is 14.
I’ve tested on Android 6 device and it’s running but not on Android 4.4.2

Do you have any ideas?

@slackmoehrle do you have any ideas or can you direct me someone?

I can build app for target level 19 and it runs on Android 4.4.2 but if I build it for target level 28 (which google forces me) it won’t open on Android 4.4.2 device even minSdkVersion is 14.

This is the error occurs on device:
java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol “__register_atfork” referenced by “libcocos2djs.so”

The problem is I have to use API LEVEL 28 to be able to publish app on Google Play and it makes impossible to compile my game suitable for older devices :frowning_face:

Let’s ask @jare to answer this.

Solution: Forget about old phones :sweat_smile: (I’m serious)

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.