Admob rewarded doesn't give a reward

Admob rewarded doesn't give a reward
0.0 0


Admob rewarded videos worked fine for me, but since I updated admob plugin, the ‘reward’ function just doesn’t work. It still works fine in older versions of my app.
I am sure I didn’t change anything that touches rewarded ads implementation in my app.
Am I the only one with this problem?


I’ll check this issue. And what os and plugin version u use?

iOS/Android ? or or ?


Android. Plugin version
Engine version: 3.16. Tried on 3.13.1 - same result.
targetSDK "24
Just tested cpp files from Admob sample in my project. Same result. ‘reward’ function just doesn’t get called for some reason.

Created a new project with Cocos2d-x 3.16, imported Admob plugin, added cpp files from Admob sample, changed json file to the one from the sample, set target sdk to 24 (if I’m not doing this I’m getting “ERROR CODE NO FILL”) - reward function doesn’t get called…


Thanks, I’ll check the issue.


set target sdk to 24

    virtual void reward(const std::string &name, const std::string &currency, double amount) {
        INFO("%s:%s, currency=%s, amount=%.1lf", __FUNCTION__, name.c_str(), currency.c_str(), amount);



Can you double check if your admob is in testing mode?