AdColony stuck loading video

AdColony stuck loading video
0

AdColony video gets stuck loading on Android 6.0.1 (BQ Aquaris 5) when it used to work fine…

The SDKBOX version and AdColony plugin have not changed since last time it worked… (sdkbox v1.0.2.8 and adcolony v2.4.3.5). The sdkbox list also says that adcolony v2.4.3.3 is installed, that is due to an update some time ago…

I’ve also tested on Android 8 and 9 and it works just fine…

I’ve tried to change the Android SDK config but doesn’t make a difference, these are the 2 that I’ve tried:

PROP_COMPILE_SDK_VERSION=27
#PROP_COMPILE_SDK_VERSION=26
PROP_MIN_SDK_VERSION=21
#PROP_MIN_SDK_VERSION=23
PROP_TARGET_SDK_VERSION=27
#PROP_TARGET_SDK_VERSION=26
PROP_APP_PLATFORM=16
#PROP_APP_ABI=armeabi-v7a
PROP_APP_ABI=armeabi-v7a:arm64-v8a

Not sure what’s going on, the onAdColonyStarted is called with the "video" and "v4vc", when all my videos in the json config have custom names, then when I invoke sdkbox::PluginAdColony::show("my_video");, onAdColonyStarted is called again with “my_video”, the AdColony activity launches, and nothing happens… AdColony screen gets stuck with a spinner (trying to load the video???) and no other callbacks are called (neither onAdColonyChange, nor onAdColonyFinished nor onAdColonyReward…)

Any ideas ideas will be much appreciated!

Thanks in advance.

you do not change anything, and it can not work on Android 6.0.1 ?

I have checked, and I overlooked some stuff, I did change some stuff to create the 64bit build due to Google’s warning for 64bit apk. I will double check and post more details about this.

UPDATE: there were changes indeed in the Application.mk for the 64bit build, plus I have upgraded the NDK from r16 to 20, but it doesn’t matter anymore, I’ve done a clean build again and now seems it works fine also on Android 6… I guess we can solve this. Thanks.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.