[3.17] Weird graphical glitch regarding using scrollView with clipping

[3.17] Weird graphical glitch regarding using scrollView with clipping
0.0 0

#1

Dear esteem developers of Cocos2d-x:

I am encountering a weird graphical glitch when using multiple scrollViews/clipping with large amount of children. It seems as I add more and more children sprites into the scrollViews, the entire rendering of its content sprites begins to incrementally shift towards the bottom, leaving a transparent gap that becomes thicker and ticker. Any idea what could be causing this problem? rolling back to 3.10 fixes the graphical issue, but the CPU of using clipping for scrollView becomes unbearable.

Untitled

the left image is what it should look like normally, while the right image shows the scrollView contents starting to split away from each other, leaving a thick black background.

Thanks for any help.


#2

Can you please post larger images of both so we can see easier what is going on?


#3

Apologies, here is a a larger image.

The top chart shows how the clipping (masking) starts breaking apart when those colored sprites start populating the chart.
The middle one is how it should look like, it’s usually fine at the start.
the bottom chart is just for reference on where the masking/clipping/scrollview nodes exist.

I’ve tried using scrollviews, panels with clipping (cocos studio), clipping node, but it seems like the problem is the same. Again, the problem disappears when using 3.10, but the CPU becomes very high.

The reason a scrollview is used is because when the sprites reach the end of their respective charts, it’s suppose to scroll to the left to create a new column.

There can be as many as 8 of these charts in the scene.

To emphasize, the red/blue marks are added one at a time and the problem seems to get worse and worse as they are being added

edit: further testing shows that you don’t even need the red/blue markers for the scrollviews to start rendering incorrectly. It seems as long as there are a lot of them and adjacent, they start rendering incorrectly


#4

@drelaptop any thoughts?


#5

This may be a shot in the wind, but I have a hunch that is has something to do with gl scissors vs stencil.


#7

Guys please create simple code test case.


#8

UPDATE: We’ve decided to hunker down and spent the day migrating to cocos creator (was using cocos studio) and it turns out all these problems disappear. Thanks for everyone’s time, I think can mark this issue as resolved for now.


#9

congratulation, I think there is no need to mark this as solved, because this is still a important issue for cocos2d-x.

recently more than one developer make feedback for the core renderer related issues, and hold the same situation that occurs on 3.17, not occurs on older version such as 3.15, 3.14.1. could you give some help when you free. @zhangxm

another core renderer related issues is