[3.0RC1] Adnroid emulator crash

[3.0RC1] Adnroid emulator crash
0.0 0


What’s the issue?
Game can run on real device, but not on android emulator “AVD”

What’s the engine version?

How to reproduce it?
Try to run CppTest (for example) on android emulator (4.2.2, API level17)

Additional inf:
NDK Toolchain version 4.7
Latest android-sdk-windows



Enable Host GPU.
Make sure RAM is not greater than 256MB.



Try to test it with a real device. AVD is very slow and error-prone.



Thanks for the advice, in 3.0RC0 AVD works just fine (testing the same project), but in 3.0RC1 it does not work; just crash.

Maybe its about the new “android NativeActivity?” or something else, I need to know if it is a bug or it is just me?

AVD is used just for multi-resolution test (at least it work for this).
Gpu Host enabled, 512 Ram.

Any idea ?


I’m having problems when running on Android using RC1 too. RC0 worked perfectly, but a new empty project gives me the attached error:

Unfortunately, ProjectName has stopped.

Tried Host GPU on and off.

Fingers crossed for a solution :slight_smile:


rc1 removed the use of NativeActivity, afaik.
Could you please post the logcat messages prior to the crash?


“Logcat” from eclipse.