wglChoosePixelFormat error win-7

wglChoosePixelFormat error win-7
0.0 0



When i try to compile test from cocos2d-x example, i get an error saying…

PVR: called a function “wglChoosePixelFormatARB” which is not present on the machine. What could be the reason. My machine is running windows - 7 btw.



ye, your video driver may be too old, upgrade your driver.


I have the same problem, I have a Radeon 5700 and have updated to the latest drivers from their website but still no joy.

Any more pointers?


hello, several developers have reported the problem, the reason is that some old video cards don’t support PVR library, and all of them solve the problem by upgrading their driver.

have you installed the right driver and restarted your machine?


Yes, I have installed the latest driver and restarted. The graphics card is only a couple of years old and was quite high end.


It depends on the description of POWERVR Insider SDK http://www.imgtec.com/powervr/insider/sdkdownloads/index.asp#GLES1b

Note : Our OpenGL ES 1.x PC Emulation requires a graphics card that supports OpenGL 1.3 or higher. The SDK has been successfully tested with ATI Radeon X1000 series and newer graphics cards and NVIDIA GeForce 6 series and newer graphics cards. Most Intel integrated graphics chipsets are not supported.


Hmm, I have the same problem with next configuration:
Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
Processor: Intel® Core™ i5 CPU 750 @ 2.67GHz (4 CPUs), ~2.7GHz
DirectX Version: DirectX 11
Card name: NVIDIA GeForce 6600 (Microsoft Corporation - WDDM)
Driver Version:


It would appear that I get the same error when running the demo apps in the POWERVR SDK. Methinks maybe a new graphics card is required, any recommendations?


I noticed this problem at Nov.2010, and described it in a FAQ in Chinese [[开发常见问题答疑]], at the bottom of this wiki page, you can see this image

Is it the right one you see?
Some people fix this problem by update their video card driver, someone re-intall the whole windows system (omg, wtf!)…
But I do have no idea how to resolve it completely. It’s caused by the compatibility between PowerVR OpenGL ES 1.1 and the desktop OpenGL interface.


Yes, that is the same problem. I don’t really want to install the OS again. What .dll is the wglChoosePixelFormatARB function in?


the ultimate solution is to replace your video card :smiley:


Any recommendations?

Would a Geforce 440 GT do the job? I assume so as it’s later than a 6600.


:frowning: sorry, i don’t quite understand which series of cards support pvr well.
maybe walzer could give you some information.


@Neil Brightcliffe
To be honest, luck is very important here. I don’t know which video card & driver can run the PowerVR SDK, which one can not.
You can download the PowerVR Insider SDK from imgtc.com website, and try if you can run their demos. If the demos cannot run, especially wglChoosePixelFormatARB crash, so do cocos2d-x. But if you can run most of the PowerVR SDK demos, maybe we can find a way to “hack” cocos2d-x to passby wglChoosePixelFormatARB function.


I’m game for that, I will download the SDK and see what I can come up with.

Oh, and thanks for you help people. :wink:


None of the samples run in the demo and the training, the wglChoosePixelFormatARB is called during a call to eglChooseConfig. This is used to find an EGL frame buffer configuration, which is then used to create the EGL context. This is quite integral to the system and I would guess that it would be extremely difficult/impossible to get around this.


For information I got my greasy hands on a GeForce GTS 450 and it works great.

Thanks guys.


We’re evaluating using OpenGL instead of PowerVR SDK on windows.
The pro is it will compatible with more video cards, the con is developers will be puzzled when they try to debug OpenGLES functions (especially debug in their extensions) on PC.
How about your idea, Neil?


How will using OpenGL confuse developers when debugging OpenGLES functions?

Primarily I am using cocos2dx to develop for mobile platforms, so debugging OpenGLES is essential.


Not that I expect running OpenGL over RDP is very practical, but the same error will be given if you are attempting to run whilst connected using Remote Desktop. Apparently RDP doesn’t use the hardware for it’s display.