Visual Studio 2010 express install templates

Visual Studio 2010 express install templates
0.0 0


I have installed the templates using install-templates-msvc.bat included with cocos2d-2.0-rc2 but when I create the new project relative to the source files, the “create new project” wizard that pops up throws lots of warnings and won’t create a new project from it.

I am using Visual Studio 2010 C++ express, running on Windows 8 Release Preview.

Thanks for any help


This problem is strange.It installed correctly for me. But it is throwing errors for me

Error 3 fatal error C1083: Cannot open include file: ‘cocos2d.h’: No such file or directory d:2d-1.0.1-x-0.13.0-beta\cocos2d_samples\cocos2d_samples\classes\helloworldscene.h 4

Error 1 fatal error C1083: Cannot open include file: ‘CCStdC.h’: No such file or directory d:2d-1.0.1-x-0.13.0-beta\cocos2d_samples\cocos2d_samples\win32\main.h 11

Error 2 fatal error C1083: Cannot open include file: ‘CCApplication.h’: No such file or directory d:2d-1.0.1-x-0.13.0-beta\cocos2d_samples\cocos2d_samples\classes\appdelegate.h 4

At run time of hello world.

Then I have created project in the source of cocos2d and opened the project manually.


Maybe you can copy cocos2d-2.0-rc2/cocos2dx to your project


I can set up the project manually if I wished to, I am just wondering why the errors are been thrown in the first place!
They are all javascript errors which appear when the Application Wizard tries to open


For anyone that may be able to help out, I have attached a screenshot of what comes up for the Application Wizard.
The Cancel button closes it, the Help button opens a page that doesn’t exist in the little window, and the Finish button shows an error box.


I got the same error message (same as your screenshot).

Any solution yet?


I tested out on a collegues computer and narrowed it down to either it been a problem with express (less likely) or a problem with running it with windows 8, as it worked fine on his computer with windows 7 and vs2010 ultimate.

My solution was just to hack apart and use the HelloWorld solution as a starting point for projects!


Open cocos2d-win.sln file .Right click on the solution add>new Project.
In the cocos2d-x templates installed ,create a new project and choose the directory as cocos2d-x root.After the project is created,
Now right click on the project debug>startnewinstance. The project runs. What happens is executable is present in Debug.win32 in cocos2d-x root folder. If you want to execute it copy all the resources to this folder , the exe runs.


The problem is that the templates are not installing correctly…not that we don’t understand how to get it running =P


It installed correctly with my visualstudio 2008. I think it’s problem with your visual c++.


I think it is platform related problem. I am using Windows 8 too.


I had a feeling it was to do with Windows 8…silly Microsoft changing the way things work :wink:


Just did a investigation.
in template\msvc\CCAppWiz.win32\HTML\1033\default.htm line 322 “setDirection();”

This “setDirection” doesnt seems to be defined anywhere. It looks a bit better after commenting this line.
Any idea?


I solved it. I can now create project.

  1. add in line 4 in both default.htm and features.htm .
  2. unblock “install-templates-msvc.bat”
  3. done


Nice one =D Thanks a lot for that