Using ver2.2 with Visual Studio Express 2013. Can't build, don't have the templates

Using ver2.2 with Visual Studio Express 2013. Can't build, don't have the templates
0.0 0


Hello everybody!

I’m new to all this cocos2d-x world, and I’m doing my best to understand everything.

But I’m having problems trying to execute the file build-w32.bat (“”=vsvars32.bat“” is not accepted as internal or external command) so I can have a cocos2d-x template inside Visual Studio Express 2013, can someone help me?

Thanks in advance.


just start the visual studio solution and compile it with visual studio. I wasn’t sure why do you need template now but just in case, use the project creation tools located under tools\project-creator\ to create new projects.


Hey zhi, thanks for your response.

I think I’m missing something here. If I’m going to compile it with visual studio, how do I first create the project in visual studio?


Did you see the file cocos2d-win32.vc2012 at the same level with the Launch it and compile from visual studio. And to create the proejct, refer here, it will create projects for multiple platform at once but you just have to deal with win32 platform.


Hey Lovepie, thanks for your response.

I’m still in trouble. I think the best way to have a progress is to sit back a bit.

I already have both the Visual Studio Express 2013 and the Python installed. The file build-win32, when I run it gives me errors, and the file cocos2d-win32.vc2012 starts copying and updating files to the Visual Studio, but I don’t know what to do next.

All I want is to try to execute the Hello World project and start a new one.

Thanks so much for your help!

EDIT: I have Windows 7 by the way, I think that’s the problem…


the same problem ….
i use Visual Studio 2013. and when i click the “build-win32.bat” bat file 2 execute , but not success. same error msg:vsvars32.bat is not accepted as internal or external command……

and then i open the “build-win32.bat” file with textedit, check the code, i found there no defined the Visual Studio 2013’s environmental variables….

I do not know how to write batch command …. can someone help ……

other error msg :
C:Files (x86).Cpp\v4.0\V120\Microsoft.Cpp.Pla
tform.targets(64,5): error MSB8020: The build tools for Visual Studio 20
10 (Platform Toolset = ‘v100’) cannot be found. To build using the v100
build tools, please install Visual Studio 2010 build tools. Alternative
ly, you may upgrade to the current Visual Studio tools by selecting the
Project menu or right-click the solution, and then selecting “Upgrade So
lution…”. [F:2d-x-2.2\external\Box2D\proj.win32\Box2D.vcxproj]


The build is for visual studio 2012… 2013 needs some different settings… best to use 2012


Had the same problem, I use VS Express 2013 on Windows 8.1. What I did to fix it was to select all the projects, right click > Properties> Platform Toolset -> Visual Studio 2012 (v110) from the list. I’m using VS in Spanish so I’m not sure about the exact name of the labels but I hope this info will give you a possible hint on your problem, at least, it worked for me :slight_smile: