Unable to Add New Project using VS2010 Pro - Windows 7


#1

Hi, I am having trouble to create the new project using the VS2010 Professional.

I followed the tutorial to set up Cocos on Windows 7.

When I try to install the templates I get the “Error: Cannot copy file (Permission denied)”. It is the same even if I ran it as administrator or from the cmd prompt.

I am using Cocos version 2.1beta3-x-2.1.1.

I also tried unblocking the html/1033 files, but nothing seems to work, and I can not add a new project.

Can any one help me on this?


#2

Hi, If you are having trouble installing 2dx templates you can try the following steps.

  1. Download the attached file, extract it.
  2. open the file CCAppWiz.win32.vsz
  3. Now check for Param="ABSOLUTE_PATH , edit this path according to your cocos2d-x folder (mine is located at D:2d-2.1beta3-x-2.1.0\cocos2d-2.1beta3-x-2.1.0\template\msvc\CCAppWiz.win32)
  4. Save this file.
  5. Now copy Cocos2d-x folder , CCAppWiz.win32.ico, CCAppWiz.win32.vsdir and CCAppWiz.win32.vsz form cocostemplate.
  6. Go to C:Files\Microsoft Visual Studio 10.0\VC\vcprojects and paste the copied content.
    7)Restart Visual studio, and you should see the option for new cocos2d-x project:)

#3

Great!

It worked perfectly!

Thanks!