Trouble installing cocos2d-x on mac

Trouble installing cocos2d-x on mac
0.0 0


Make a New Game
$ cd cocos2d-x
$ ./
$ source ~/.bash_profile # may be ~/.bash_login or ~/.profile, depends on your environemnt
$ cocos new MyGame -p com.MyCompany.MyGame -l cpp -d ~/MyCompany

Carls-MacBook-Air:~ carljalal$ cd cocos2d-x
-bash: cd: cocos2d-x: No such file or directory

So… now what?


what version of Cocos2d-x? are you using the download of v3 rc0 or the latest from github?

Downloading the latest works just fine.

Downloading the latest from github fails as it doesn’t seem to be downloading all the files…when i look cocos2d-x-develop/tools/cocos2d-console/ is empty!


I’m on v2.2.3 because it also supports the windows phone, but I think I’ll just go and download the v3 and see if it works


I downloaded rc0 and… it still doesn’t work. Are there any examples/videos of just downloading and installing cocos2d-x that exist? Cocos2d-3.0 for iphone was just download and click the install button.


Download this:

I just did and here is a pic


Thanks! I guess that worked.

So, how should I write the game so that it can be submitted to all the android/ios app store?
Should I write it in Xcode or Eclipse?


You will need to use both. XCode for ios and Eclipse (or whatever else) for Android.


So… when I change it in XCode does it get changed for Eclipse? (Or do I need to copy and paste it back and forth?)


umm, no, it gets changed. That’s the point of how the file structure is setup the way it is. IDE’s should always share source trees.

You will have to re-compile though which is standard procedure.


Oh good!

So how about this to run “MyGame” from XCode?

I wrote this:
$ cocos run -s ~/MyCompany/MyGame -p ios

And it only opens in 3.5 retina, but what if I want to test it on my phone from XCode?
The XCode project has lots of schemes, such as mac, ios, etc. I tried building many schemes (any they succeed), but none of them run a template


you open up the MyGame.xcodeproj and select your target from the drop down and run it.


I seem to have a different view:
Maybe I didn’t install or build something correctly??


I just saw the screenshot. Can you not select HelloWorld IOS -> whatever simulator you want to run it in

Then Command-B to build or Command-R to build and run.


Unfortunately not. In fact, I have tried each and every one of those, and nothing will run. Each of them builds successfully and but does not run.


I’m not sure how to help anymore without being in front of your screen. I ran this again and tried to compile and everything works for me.


I have just one simple question which might solve this problem.
I have this screenshot where is says "Enter cocos2d-x/build and open cocos2d_tests.xcodeproj"
It would be nice if it said where to enter “cocos2d-x/build” Where? In the terminal? In what directory?


by ‘enter’ I think they mean just browse the folder in the Finder. That is all I do.

Your not by any chance around me in cali are you?


Oooh I found it. I feel dumb. Yeah I just want to the build folder and found the project there.

I’m actually in Korea but I rarely sleep becuz I’m trying get my hands on this hot cross-platform stuff.


dont feel dumb. at least you are putting in effort and not just asking for a handout.

keep in touch. I’d love to collaborate. I am about to release my first title and I have a binder with 40 more.


Sure. what’s your email/messenger? mine is . I have a few games in the app store made with cocos2d for iphone.