TMXTileMap artifacts (possible bug)

TMXTileMap artifacts (possible bug)
0.0 0


I’ve been working for a while on getting this working on Linux, which I finally did. Unfortunately, I’ve run into a few issues. The most noticeable of which is this from the TestCpp sample. Please forgive all the links:

orthogonal-test3.tmx, sample location

orthogonal-test3.tmx, sample location

At first I thought this was an issue with the Linux build, however, it is also doing this on a native build for Android (running on my Nexus 7).
Is there any way to fix this? I’ve tried running the tmw_desert_spacing.png file through the from cocos2d, but that didn’t work. Additionally, I tried removing the scaling from the samples, but those didn’t change it either.

Am I doing something wrong? Is anyone else running into this, or is it just me? Either way, would it be good for me to file a bug report?


Try setting




That makes it go away for me. On both Cocos2dX and Cocos2d.

Just a suggestion, worked for me, your mileage may vary.


Well, it works… it just doesn’t work for anything over 100px, I think. It’s really a dirty hack and the underlying issue is a bit deeper than the surface shows… I have no idea what would actually be causing this though.


We had the same issue up on codeplex for cocos2d-xna. It only appeared on certain hardware devices, e.g. xbox 360. DO you have antialiasing enabled on your device?