Successfully Run Cocos Creator on Linux and released it as docker image

Successfully Run Cocos Creator on Linux and released it as docker image
0

#21

For now, this will not change. The engineering team is really over-worked and the resources producing a Linux version are to much for them to handle. If this changes I will let everyone know.


#22

@sercand Hello. Could you share Cocos Creator v1.9.2 if it possible?


#24

Hi! has anyone tried to port cocos 2.x or provide a different tool to enable Linux builds?


#25

If you let us know what is the electron used by CocosCreator 2.0.x and 2.1.x it could be a good starting point for a new port.


#26

@pablomartinez I have released a docker image 2.0.5-web 4 months ago.


#27

Thanks! cool, I was working in porting the 2.1.0 version, notice that it is still running on electron 1.7.5, I was trying to update the atom/common/asar/archive.cc and atom/browser/net/url_request_asar_job.cc files for the asar decryption, will fight a bit with it, if i don’t success will use one of your images, thanks so much!


#28

Hello @sercand I am working in a docker image for jenkins using the cocos-creator build inside your 2.0.5-web image. When building the hello-world project I am getting following error, related with WEBGL.

Error: TypeError: Cannot read property 'getParameter' of null
    at Device._initCaps (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/renderer/render-engine.js:5051:46)
    at new Device (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/renderer/render-engine.js:5009:18)
    at Object.initCanvas (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/renderer/index.js:85:31)
    at Object._initRenderer (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/CCGame.js:362:30)
    at Object._initEngine (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/CCGame.js:108:22)
    at Object._prepareFinished (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/CCGame.js:116:22)
    at Object.prepare (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/CCGame.js:155:26)
    at Object.run (/opt/cocos-creator/resources/engine/bin/.cache/dev/cocos2d/core/CCGame.js:161:22)
    at /opt/cocos-creator/resources/app.asar/editor/page/build/build-worker.js:1:1623
    at fn (/opt/cocos-creator/resources/app.asar/node_modules/async/lib/async.js:746:34)

My docker image extends from jenkinsci/jnlp-slave, and includes the same libraries you are using in 2.0.5-web. It works perfectly with the 1.9.0-web image. Will appreciate any help :slight_smile:


#29

@pablomartinez I guess at this line of build script there is --disable-gpu flag which should not be there.
If you have the same argument please remove it.


#30

Thanks! I also had the --disable-gpu, tried removing it but I am getting the same error plus a GPU Process Crashed! message logged during the project compile process. Seems that there are more people experiencing the same issue with Jenkins on windows https://forum.cocos.com/t/windows-jenkins/65950. I also have tried installing osmesa and firing chromium with the --disable-gpu --use-gl=osmesa params to launch the GPU process without success :frowning: