Some actions don't work


#1

It seems the default HelloWorld project is missing something in its initialization sequence. For example, try to add
pLabel->runAction(CCShaky3D::actionWithRange(1, false, ccg(1,1), 10));
at the end of HelloWorld::init()

On Win emulator (not sure about other platforms) the background sprite disappears (becomes black).


#2

I realized that AdvancedEffect test in the cocos2d-x test application suffers from the same issue (see the attached image). Shake and wave actions make the background black.


#3

Today I tried CCShaky3D with an android phone. It doesn’t work too. Exactly the problem I described before. Also I found an topic (http://www.cocos2d-x.org/boards/6/topics/105) that describes an identical problem. Dev of cocos2d-x, please, may you look at this bug?


#4

Thanks for your report. But more details are required.

  1. which version / branch of cocos2d-x are you using?
  2. Which brand and type of android phone are you using? How about its android sdk version?

#5

I tried both cocos2d-1.0.1-x-0.12.0 and cocos2d-1.0.1-x-0.13.0. You can reproduce the issue with win simulator. The scenario is very simple: in HelloWorld application add pLabel->runAction(CCShaky3D::actionWithRange(1, false, ccg(1,1), 10)) to HelloWorld::init.

Please confirm that you are able to reproduce the issue. Thanks!


#6

Hi Walzer,

do you have plans do fix this issue? It is a showstopper for me :frowning:

Thanks!


#7

I tried the very last build (cocos2d-2.0-rc0a-x-2.0 @ May 31 2012). The bug is still there :frowning: In HelloWorld I added
pLabel->runAction(CCShaky3D::actionWithRange(1, false, ccg(1,1), 10))
the screen becomes black.