[SOLVED] Unable to find native library : libcocos2dcpp Cocos2d-X 3.0


#1

Hi, I’m new with cocos2d-x 3.0 and encounter a problem in android.

I use create_project.py then import proj.android in eclipse

Usually, I just link-source src at platform/android/jni/src in cocos2dx 2.1.4-2.2
And the problem has gone right away

but now eclipse return error with “Unable to find native library” libcocos2dcpp

Some have said using device instead of emulator, tried that on Samsung Tab 3 with no luck.

How to solve this problem? Thanks


Solution for this week
#2

anybody? Works great in XCode 5.0 though….


#3

you can try to just link-source src at platform/android/jni/

if it can’t be solved. u can give me u sample to my email.

yuye.liu@chuong-inc.com
Jonathan Napitupulu wrote:

anybody? Works great in XCode 5.0 though….


#4

thanks, got it….

Solved it by importing cocos2c android project and refresh it couple of times…

It may slightly off topic, since I don’t want to spam the board and there’s no docs yet,

How do we integrating 3rd party SDK on Android,

seems like iOS has no problem,
on Android there’s no sign implementing SDK in Cocos2dxActivity.java