Should I even be using cocos2d-x-3.0alpha1?

Should I even be using cocos2d-x-3.0alpha1?
0.0 0


I installed cocos2d-x-3.0alpha1 and had started working on a game using this. I googled and dug up the updated, somewhat hidden docs around here for this, but even when following the instructions to a T, I end up with errors. I post a basic question on here and it goes 3 days without a single response.

So this leads me to wonder if people are even using cocos2d-x-3.0alpha1, or is everyone still using 2.2.1? My fear with starting a new project on 2.2.1 was that it won’t continue to be supported, but it seems like the support is much better than for 3.0?




I do not use cocos2d-x 3 alpha, because it is alpha =) It has bugs, not all features are done, and some old things are not working. When it will be done, it would to be good thing, but now, AFAIK, it’s not stable.

cocos2d-x 2.2.1 is latest stable version, so I use it. You afraid of lost the support, but what the support do you need on 2.2.1 ?


Artur, thanks for the response. My concern is that once cocos2d-x 3 is officially released that continued support for cocos2d-x 2 could be dropped. Then say a new version of iOS is released that is no longer compatible it could become a bigger issue. With no definite timeline on cocos2d-x 3 stable though; maybe I will just switch to cocos2d-x 2.