SDKBOX 2.2.2 Released

SDKBOX 2.2.2 Released
0.0 0


They do work now. I had to import chart boost and vungle separately too. I might have missed that in the instructions.


Just met a problem with SDKBOX in Android;

Build process success, fail in running:

Here is the log captured:

I/AEE/AED (10501): [OnPurpose Redunant in void preset_info(aed_report_record*, int, int)] pid: 10426, tid: 10452, name: GLThread 24976  >>> com.aurorainno.GhostLeg <<<
D/Posix   (10426): [Posix_connect Debug]Process com.aurorainno.GhostLeg :443 
I/AEE/AED (10501): pid: 10426, tid: 10452, name: GLThread 24976  >>> com.aurorainno.GhostLeg <<<
I/AEE/AED (10501):     #10 pc 008b45f8  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (_JNIEnv::FindClass(char const*)+40)
I/AEE/AED (10501):     #11 pc 00a62acd  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (sdkbox::JNIUtils::GetClassObjectFromName(char const*, _JNIEnv*)+20)
I/AEE/AED (10501):     #12 pc 00a631a7  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (sdkbox::JNIUtils::GetJNIStaticMethodInfo(char const*, char const*, char const*, _JNIEnv*)+26)
I/AEE/AED (10501):     #13 pc 00a61a9f  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (_ZN6sdkbox15JNIInvokeStaticISsIEEET_PKcS3_DpT0_+30)
I/AEE/AED (10501):     #14 pc 00a61c05  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (sdkbox::SdkboxCore::getChannel() const+12)
I/AEE/AED (10501):     #15 pc 00a6471f  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (sdkbox::ConfigManager::getConfig(char const*) const+118)
I/AEE/AED (10501):     #16 pc 00a5ee79  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (sdkbox::SdkboxCore::getConfig(std::string const&) const+8)
I/AEE/AED (10501):     #17 pc 008bdfe1  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (sdkbox::IAPWrapperEnabled::init(char const*)+76)
I/AEE/AED (10501):     #18 pc 008bc7ff  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (sdkbox::IAP::init(char const*)+14)
I/AEE/AED (10501):     #19 pc 007e3354  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (AppDelegate::applicationDidFinishLaunching()+40)
I/AEE/AED (10501):     #20 pc 008adcd0  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (cocos2d::Application::run()+40)
I/AEE/AED (10501):     #21 pc 008b1068  /data/app/com.aurorainno.GhostLeg-1/lib/arm/ (Java_org_cocos2dx_lib_Cocos2dxRenderer_nativeInit+224)
I/AEE/AED (10501):     #22 pc 0017660d  /data/dalvik-cache/arm/data@app@com.aurorainno.GhostLeg-1@base.apk@classes.dex
V/AEE/AED (10501): dashboard_record_update() : rec->module = com.aurorainno.GhostLeg 
W/InputDispatcher(  844): channel '367c62bb com.aurorainno.GhostLeg/org.cocos2dx.cpp.AppActivity (server)' ~ Consumer closed input channel or an error occurred.  events=0x9
D/InputDispatcher(  844): channel '367c62bb com.aurorainno.GhostLeg/org.cocos2dx.cpp.AppActivity (server)' ~ abortBrokenDispatchCycle - notify=true
E/InputDispatcher(  844): channel '367c62bb com.aurorainno.GhostLeg/org.cocos2dx.cpp.AppActivity (server)' ~ Channel is unrecoverably broken and will be disposed!
I/WindowState(  844): WIN DEATH: Window{367c62bb u0 com.aurorainno.GhostLeg/org.cocos2dx.cpp.AppActivity}

Please help!!!


Looks like your sdkbox.jar is still old version, can you copy the latest sdkbox.jar in the package to replace the ones in your project?


How to download the latest “sdbkox.jar”??
btw, In my cocos2d engine java libs folder, the update time is correct, same as the time I did the ‘sdkbox update’


if you use sdkbox update the sdkbox.jar file should be in following folder



I never sign out but sdkboxplay let me choose my account once two starts and when it happens it does not connect (and the sdkboxplay callbacks are not called in this case). I’m using sdkboxplay
the other times it auto connects without issue so it works half the time.


Hello @nite,
Can you help me check the sdkbox.framework and PluginFacebook.framework was broken or not, because when my project link to this framework and they can not find the framework header, it gen the compile error ( cannot find the header PluginFacebook.h)
p/s i am using the package
Thanks in advance


PluginFacebook.framework should contain the necessary headers, can you double check your link settings and make sure it’s in your header search path and linked library path.


thanks for your reply, can you show me how to config the header search path with the framework. AFAIK, when we add the framework in xcode, we won’t care about the header, i already tried add to header search path where i put the framework, but it doesn’t work. :frowning:
thanks again


hi @nite
problem solved, i downloaded the zip file to windows, and committed to git, this made the framework corrupted somewhere, just redownloaded in Mac, and the problem gone, :smiley: