run cocos2dx sample on linux

run cocos2dx sample on linux
0.0 0



i downloaded cocos2d-2.1beta3-x-2.1.0 and install it on a linux debian.
i run the command ./, no problem
i tried to run a sample, like TestCpp or HelloCpp in /cocos2d-x/sample/Cpp/HelloCpp/proj.linux
but nothing append …

any ideas?

thx a lot


Try running from console and watch output.


i did too
but may be i misspelled something, i m not use to command line
could you give me the command please?

i m not using android package, could it be the reason?


by the way :
the wiki linux env setup link give an empty page


some additional information :
i want to develop for linux not from a linux
in the package /samples/TestCpp/proj.linux i have main.cpp, main.h and Makefile



If succeeded you should have binary for TestCpp in samples/TestCpp/proj.linux/bin/debug. Try running it from command line and see what happens.


indeed, i got an error, thx

In file included from …/kazmath/src/mat4.c:40:0:
…/kazmath/include/kazmath/neon_matrix_impl.h:31:22: fatal error: arm/arch.h: No such file or directory
compilation terminated.
make: * […/kazmath/src/mat4.o] Error 1
make: Leaving directory `/cocos2d-2.0-x-2.0.4/cocos2dx/proj.linux’

i checked on the folder /cocos2d-2.0-x-2.0.4/cocos2dx/proj.linux and mat4.o file do not exist
but its seems to come from arm/arch.h