RenderTextureTest not works in TestCpp (cocos2d-x 3.0 alpha1 and 2.1.5)


#1

Hi, I have a problem with first RenderTextureTest (cocos 3.0 alpha1 and 2.1.5)

After a background/foreground I’m not able to draw nothing.
I see the cursor (fire.png) below my finger, but nothing render

This happens with Kindle and other Android devices (I suppose with Qualcomm graphics card)
Amazon rejected my app due to this issue.

I have made some test:

  • if I set CC_ENABLE_CACHE_TEXTURE_DATA = 0, problem mentioned above is resolved, but there are others (like black textures).

  • If I commented some line in listenToBackground and listenToForeground (in the RenderTexture.cpp)

listenToBackground()
glDeleteFramebuffers(1, &m_uFBO);
m_uFBO = 0;

listenToForeground()
glGenFramebuffers(1, &m_uFBO);

It works with standby button, but not with home button.

Do you know if this bug is under works? If there is some workaround?

thanks for help
Don


#2

is there someone that could help me?


#3

That is an odd report. TestCpp works very well on my Kindle and our applications were accepted by Amazon.

Have you tried 2.2?


#4

Thanks for reply
Evidently, I have explained badly.

However, I have just tried with 2.2.1.
Same issue.

I repeat the simple test that I have performed:

  1. Run TestCpp on Amazon Kindle Fire HD (also many other devices)
  2. Choose RenderTextureTest
  3. Draw something
  4. press stand by button to turn off
  5. press again stand by button to turn on
  6. unlock device
  7. draw something

TRAAAKK

NO drawing

If you are able to drawing, that’s curious.
Or my hardware is different or I wrong something in the import and setting of the project

Could you tell me if you are able to drawing?

thanks
Don