Problem with TestJavascript on device

Problem with TestJavascript on device
0.0 0



I have a problem when I run the TestJavascript on my device (Samsung Galaxy Tab 2).
The program shutdowns with an error : “TestJavascript stopped”.

This is what it seems to be the relevant part of the logcat :
W/dalvikvm( 6093): Class init failed in newInstance call (Lorg/cocos2dx/testjavascript/TestJavascript;) D/AndroidRuntime( 6093): Shutting down VM W/dalvikvm( 6093): threadid=1: thread exiting with uncaught exception (group=0x40bcb1f8) D/KeyguardViewMediator( 210): setHidden false E/AndroidRuntime( 6093): FATAL EXCEPTION: main E/AndroidRuntime( 6093): java.lang.ExceptionInInitializerError E/AndroidRuntime( 6093): at java.lang.Class.newInstanceImpl(Native Method) E/AndroidRuntime( 6093): at java.lang.Class.newInstance(

I compiled with build_native, I used Ant to build the Apk and then ADB to put it on the tablet.
This manipulation worked fine on Cocos2D-x 2.0.3, with the same TestJavascript, but do not anymore with the 2.0.4 version.

What am I doing wrong ?
Does someone have an idea ?

Thank you !


I,m run SimpleGame so that.