problem with CCHttpRequest

problem with CCHttpRequest
0.0 0


Hello friends,
I am developing my first game in Cocos2dx for android(on windows, visual studio 2010)…. Currently i am facing problems in establishing Http connection(to our server).
When i am using my URL in TestCpp’s HttpClientTest, i am getting the response and it is working fine.

But when i am using the same code from that sample and the tutorial given on the wiki page:, in my project, error occurs during compilation.

it states identifier “CCHttpRequest” is undefined’… i have included all the necessary header files and also imported all the header and cpp files but still i am getting some errors in the IDE (VS 2010)…

if there is some other steps that i might be missing to make HTTP connection, plz let me know…

It would be very convenient for me if any one can guide me step by step…

Thanx in advance.


Full class name is cocos2d::extension::CCHttpRequest. You can use using namespace cocos2d::extension.


Thanx for the reply n sorry for my late reply….
It is still not working. when i write the following statement,

cocos2d::extension::CCHttpRequest * request = new CCHttpRequest();

it still gives the error that “name followed by ‘::’ must be a class or namespace”…
i am using cocos2d-2.0-x- 2.0.4. The Http sample in TestCpp has following statement,

CCHttpRequest * request = new CCHttpRequest();

But when i copied it in my code it is giving me error…



cocos2d::extension::CCHttpRequest * request = new cocos2d::extension::CCHttpRequest();


thanx bro for the reply but it is giving me the same error….
i guess there is no namespace or class defined as ‘extension’….
do i have to include some header file also???