Problem with accelerometer on Android platform

Problem with accelerometer on Android platform
0.0 0


Hello everyone.
I want to try to use cocos2d-x in my projects. But on my first stage I’ve got a problem with accelerometer on Android OS.
So, I followed tutorial by Jean-Yves Mengant and tried to develop Space Game step by step like in tutorial
I used cocos2d-x 2.0.1 (2012-06-29) meanwhile in tutorial is used earlier version. I’ve integrated all parts of tutorial except sounds and collisions. When I ran my code on iPhone 4S it worked ok, bu when I ran it on HTC Sensation(Android 4.0.3) and Amazon Kindle Fire(Android 2.3.3) I could not manipulate my ship by accelerometer. But when I ran source code from tutorial it works well both on iOS and Android OS devices.
I’ve attached HelloWorldScene.cpp source code.
Thank you for your help (2.5 KB)


I also get into the same problem. On note 2, the spaceship does not move with the acceleration. And then on sony tablet, the spaceship disappears.