Problem using paths on xcode 5

Problem using paths on xcode 5
0.0 0


Hi, I create a project with cocos2d-x 2.2.2 using javascript.

I create cocos builder project to integrate with my app.

But when I run this project I receive the following error

Cocos2d: Get data from file(fonts/scorefont.fnt) failed!

Not only this error, but I receive many other errors that say other files failed to be located, I think this could be a problem related to xcode.

I did this in my config file that reference some files using the path, “res/GameScene.js”. I receive the same error, then I change the config file to reference only “GameScene.js”, I remove the folder and it works. But it’ll be troublesome to change all my files to root folder because I use cocos builder.

I want to know how I can add my files to the correct path inside Xcode that my code could reference it from the correct path like “fonts/scorefont.fnt”, instead of “scorefont.fnt”(not using the folder reference)


I resolve the problem. Now I use the folder reference option when I drag and drop the file inside Xcode. Earlier, I was using the group reference folder, it’s because that it’s not working.