Problem running with 3.0

Problem running with 3.0
0.0 0


Hi all, I’ve downloaded the new “Cocos2D-JS”, successfully created a new project with cocos new projectName -l js and compiled it with cocos compile -p android (which, by the way, took an incredibly long time to complete). But now, if I try cocos run -p android I get stuck at “- waiting for device -” in the console. Any clues as to what to do?

By the way: the generated .apk is good, I’ve tested it with Bluestacks (another android emulator) and it works fine.


Hi, have you opened your emulator or plugged your Android device when you run the command ? If not, the script can’t open them automatically because they don’t know where to find the device.


I’ve tried having the emulator running (the virtual screen is shown all black and there are buttons on the side) before running the command, but it still won’t do anything.

Are there any logs or diagnostics I could run maybe?


Hi, @ZippoLag,

We may have some issue on certain machine and emulators in the alpha version. Can you try to run it on your real android device? There is less problems on devices. We will fix the problems in the next version.



Sadly I don’t have a physical device to test it on. But I will see what I can manage when I get home tonight.


Sorry for bumping this. What do I have to connect a physical device as? I’m getting stuck at “waiting for device” as well. I’ve tried connecting my galaxytab as mass storage but also using the “samsung kies” thing, but the cocos console does nothing and still seems to wait for the device.


Nevermind, I have to set the device to debug mode. Now I have errors when it’s actually trying to run, but I’ll probably create a separate thread for that.