Problem in running HelloWorld using ndk r6

Problem in running HelloWorld using ndk r6
0.0 0


I have followed except that I have used ndk r6 from google instead version from crystax also changed nothing in cocos2dx/ and

But when i try to run I always get this error.
StaticLibrary : libstdc++.a
Prebuilt : libstlport_static.a <= /sources/cxx-stl/stlport/libs/armea
SharedLibrary :
xe: D:/projects/ccd/cocos2d-x/HelloWorld/android/obj/local/armeabi/libstlport_st
atic.a: No such file: Permission denied
collect2: ld returned 1 exit status
make: * [/cygdrive/d/projects/ccd/cocos2d-x/HelloWorld/android/obj/local/armea
bi/] Error 1
make: Leaving directory `/cygdrive/d/projects/ccd/cocos2d-x/HelloWorld/android’

How can I fix this? Im using cocos2d-1.0.1-x-0.9.1 btw.
Thanks in advance.

issue when build HelloWorld in Cygwin

I will try it now.


I have built with ndk-r6, it worked ok.
My codes is the latest of github, but the .mk file is the same as cocos2d-1.0.1-x-0.9.1.

No such file: Permission denied

It seems you have not permission?


yes, changing the mode of the file solved the problem.

chmod a+rw libstlport_static.a

Thanks for the immediate response. =)