PlayEffect does not play sound

PlayEffect does not play sound
0.0 0


We are using backgroundmusic.wav and tap.wav to play sound in the game.

If we the play any sound file using playBackgroundMusic method it works fine.
SimpleAudioEngine::sharedEngine()->playBackgroundMusic(“tap.wav”) [THIS WORKS]

However, if we use playEffect method we do not hear the sound.
SimpleAudioEngine::sharedEngine()->playEffect(“tap.wav”) [DOES NOT WORK]

Yes we are preloading the sounds.

Has anyone is this situation? Can I answer any other question to help me find a solution?

I am working on WinRT, since winphone is the closest match I am using that form to post this message.



We have also used afconvert to covert the file to right format as suggested in one of the posts.


I’m not familiar with winrt environment. But could you upload your tap.wav file, then I can ask my coworker to reproduce this bug on wp8?
By the way, which version cocos2d-x for winrt/wp8 are you using?


I have the problem like it.
In the past sound effect works good in XCode4.6 and MacOSx10.7.4.
I’m going to open it in XCode 5 and Mavericks.
But it doesn’t play sound. it play noise.
I think it is not cocos2d problem.
Please check the attached and help me.


I had the same problem.
In my case, i solved to change convert command ‘afconvert’ to ‘lame’.
(Although it’s mp3, but not wav)

for your convenience.


Is this problem is not solved yet? I also face this problem.