New Cocos2d-x based product

New Cocos2d-x based product
0.0 0


Hi, I’m not sure if this is a proper place to post about my product, since I’m using a custom build of Cocos2d-x for it and not the official version. But I thought that the community might be interested (and in the near future, it will possible to link to an external cocos2d-x build for those who may want to use the official release, or their own custom versions.). I will also be releasing the source code of my custom build to GitHub as soon as I get things cleaned up and finished. There will also be a link to my work on the WebOS and Mac OS X versions of Cocos2d-x on the website once the product officially launches.

CatHide is a tool that I created because I found it tedious to have to deal with all of the various IDEs and development environments in order to develop for Cocos2d-x on multiple platforms. CatHide is available on Mac OS X and features a unified editor and build environment for 4 platforms (6 if you count the Kindle Fire and Nook tablets). It doesn’t allow quite the same level of flexibility as creating a Cocos2d-x project from scratch on your own, but it does allow you to build your product on multiple platforms within one environment. CatHide also features its own native simulator that allows you to test on multiple aspect ratios, and will allow you to take screenshots soon.

The software is currently available for pre-order at a discounted price of $29.99. Pre-ordering also gives you immediate access to the current alpha build. There is still a fair deal of important features missing from the alpha build, but I am hoping to have it feature complete within a month and updates will be very frequent up until that point.

More information can be found at


I just bought a pre-ordered one, but it crashed at launching.
And I’m interest in if you guys developed this tool based on some open source IDE, e.g. eclipse, textmate, or write everything from scratch based on Qt?

Process:         CatHide [12086]
Path:            /Applications/
Identifier:      com.imperialpenguin.CatHide
Version:         ??? (0.6.0)
Code Type:       X86-64 (Native)
Parent Process:  launchd [294]

Date/Time:       2012-08-13 08:25:32.101 +0800
OS Version:      Mac OS X 10.7.4 (11E53)
Report Version:  9

Interval Since Last Report:          261440 sec
Crashes Since Last Report:           8
Per-App Crashes Since Last Report:   5
Anonymous UUID:                      7B796CE9-CDC9-43DF-A44E-75CBEA6709D0

Crashed Thread:  0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: QtXml.framework/Versions/4/QtXml
  Referenced from: /Applications/
  Reason: image not found

Binary Images:
       0x100000000 -        0x1002a7ff7 +com.imperialpenguin.CatHide (??? - 0.6.0)  /Applications/
       0x1002fb000 -        0x100312fff +org.andymatuschak.Sparkle (1.5 Beta [bzr] - 313) <7D298003-0E13-7E27-8237-9C0E1D621133> /Applications/
    0x7fff66a02000 -     0x7fff66a36baf  dyld (195.6 - ???) <0CD1B35B-A28F-32DA-B72E-452EAD609613> /usr/lib/dyld
    0x7fff8e1c4000 -     0x7fff8edcaff7 (6.7.3 - 1138.47)  /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
    0x7fff8f693000 -     0x7fff8f693fff (6.6 - ???) <021D4214-9C23-3CD8-AFB2-F331697A4508> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

Model: MacBookPro6,2, BootROM MBP61.0057.B0F, 2 processors, Intel Core i5, 2.4 GHz, 8 GB, SMC 1.58f16
Graphics: NVIDIA GeForce GT 330M, NVIDIA GeForce GT 330M, PCIe, 256 MB
Graphics: Intel HD Graphics, Intel HD Graphics, Built-In, 288 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353237334348302D4346382020
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1067 MHz, 0x80CE, 0x4D34373142353237334348302D4346382020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.0.5f11, 2 service, 18 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Network Service: StrongVPN, PPP (L2TP), ppp0
Serial ATA Device: Hitachi HTS545032B9SA02, 320.07 GB
Serial ATA Device: MATSHITADVD-R   UJ-898
USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2
USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0xfd110000 / 4
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3
USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa130000 / 5
USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8218, 0xfa113000 / 8
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0xfa120000 / 3


Thanks for posting the crash report. It’s a very easy fix and I’ll have it updated shortly and send you a link to get the new version (the autoupdater clearly won’t work). I have to say, I’m a little nervous having you as the first customer. :wink:


wow, first customer :slight_smile:


Okay, I’ve uploaded a new version to E-Junkie. You should still be able to use the download link that they sent you. The new file should be around 45 megabytes instead of 35. Let me know if it doesn’t download and I’ll upload the file to my server and send you a link. Let me know if it opens okay this time. Some Qt libraries weren’t included, adding them should have fixed it.
Also, as pointed out in another thread, retina macbooks have problems with cc fonts right now. I don’t know if you have one of those, but if you do the CatHide simulator won’t show fonts correctly. I’ve already added it to my list of things to fix.
I’m glad you were the first customer now. I’d hate to have dozens of people all unable to open the software. It may be in alpha still, but it should at least open. :wink:


Oops, I have no retina mbp.
15 inch is too heavy for me. I’m waiting a 13 inch retina mbp to be release in Q3 or Q4. :slight_smile:


It should work fine if you do not have a retina macbook. Did it let you download the file again?
I know e-junkie has a limit on how many times you can download the file, but I don’t remember what it is. I’m pretty sure it is more than once though.


I just wanted to pop in and let everyone know that the product has finally reached the beta phase and is available for free trial download and the special pre-order price will remain in effect until the beta period is over. This way, those of you who may have wanted to try before buying have the option to do so and still get the special price. If the beta period lasts longer than the 30-day trial, I’ll issue a time limit reset code.
All of the new products this season have put a lot of extra work involved in getting one-click functioning, so beta testers are certainly appreciated, even if they have no intentions of buying the software. So if you have any developer friends, feel free to tell them about it too.
The software can be downloaded from here:
And I recommend reading through the tutorial to see what changes were made to Cocos2d-x to make the one click, one set of resources goal achievable. That is available here:

Of course, new features will be added throughout the 1.x series. I have a lot planned for it assuming it sells well enough to justify the work. I wanted to put them all in at launch, but I realized that I would never be finished if I waited until I added everything I wanted to into the first release. :wink:

P.S. Anyone who bought the pre-order should be receiving a notification from within the software about the 0.9.0 update. If not, please let me know so I can figure out what went wrong.