Need help with

Need help with
0.0 0


Hey guys, rookie cocos developer here. I just got Cocos2dX running on my linux machine and got it to compile and upload games to an android phone (I’m interested in android game development), but I seem to have trouble with wizard file. No matter what commands I type I always get this:
File “”, line 27
print "Usage: project PROJECT_NAMEpackage PACKAGE_NAME language PROGRAMING_LANGUAGE

Here’s some commands I tried:
sudo python create_project.pyproject TestApp package com.cepa.TestApplanguage cpp
python project TestApppackage com.cepa.TestApp -language cpp
I’ve also tried using the file directory insted of cd’ing into the directory and accesing file directly, same results.

My Setup:
* Up to date version of ArchLinux
* Up to dave version of Python
* Cocos2DX v2.2
* My Cocos2DX is located at ~/Dev/Cocos2dX

So Am I that stupid or is there something wrong with my Cocos files?


use Python 2.7.6 and let me know it has been solved or not


Thank you Farid, I used python 2.7.5-2, which was already installed on my system, I just needed to use “python2” instead of “python” in the command line. Project was created sucessfully. One small question, is there any way to make the project android only? I’m not planing on developing for other platforms at this time.


Just don’t build on other platforms. Or delete everything except Classes, Resources, and


Lance’s advice is right