ndk-r7-crystaX, HelloWorld triggers Fatal Signal 11 on startup

ndk-r7-crystaX, HelloWorld triggers Fatal Signal 11 on startup
0.0 0


I’m trying to set up a HelloWorld project on my Ouya devkit using a cocos2d-x project built with crystaX NDK.

I used create-android.project.sh to create the project, then edited build_native.sh to provide the path to android-ndk-crystaX. I ran build_native.sh, and created an eclpse project from the result. After making sure Eclipse was aware of the cocos2d-x library, and fixing an icon path in AndroidManifest, I ran the App on device. The HelloWorld default project crashes immediately when the game launches, Fatal Signal 11. Prior to the crash, libgame.so is loaded, then some gl drivers, but that’s as far as the debugger gets me.

The interesting, terrifying thing is that the when the project is created through the exact same steps, but compiled against the official android-ndk-r8d, runs without a problem.

I absolutely cannot use the official NDK, as it does not support wchars. I would be setting myself back months to find a way around that, and doing so isn’t an option.

Has anyone heard of this problem when using crystaX? If there’s some fatal flaw with that, as well, I may just be completely out of luck.