NDK-Build Problem png.a

NDK-Build Problem png.a
0.0 0


I had error message like below when do build_native.sh

Using prebuilt externals
make: Entering directory `/cygdrive/d/cocos2dx20rc/KetupatWeaverAndroid/proj.android'
Gdbserver      : [arm-linux-androideabi-4.4.3] libs/armeabi/gdbserver
Gdbsetup       : libs/armeabi/gdb.setup
SharedLibrary  : libgame.so
D:/Android/android-ndk-r8/toolchains/arm-linux-androideabi-4.4.3/prebuilt/windows/bin/../lib/gcc/arm-linux-androideabi/4.4.3/../../../../arm-linux-androideabi/bin/ld.exe: ./obj/local/armeabi/png.a: No such file: Permission denied
collect2: ld returned 1 exit status
/cygdrive/d/Android/android-ndk-r8/build/core/build-binary.mk:369: recipe for target `obj/local/armeabi/libgame.so' failed
make: *** [obj/local/armeabi/libgame.so] Error 1
make: Leaving directory `/cygdrive/d/cocos2dx20rc/KetupatWeaverAndroid/proj.android'

I had tried to edit permission for NDK folder but meet no success. What do you suggest? Thanks for help


I am getting the same error :(. Did you got any luck to solve it?


Hi! Oscar Manule
Now, I faced this problem a long time, but I can’t slove it. Did you had solved it? Can you tell me? Thanks for help.


Not getting in the detail…I have solved this by using Nvidia developer toolkit for android…

It comes with all the tools and configurations with ndk and debug manager especially…
Try with that.