Mobile Browsers - setContentScaleFactor crashs game

Mobile Browsers - setContentScaleFactor crashs game
0.0 0


Hey guys, me again!

I know that I am the most dumb guy just trying to make use of IE here, but common it is a nice browser that still needs to be supported :stuck_out_tongue:

Just found that if I call setContentScaleFactor the game crashes at the loading, I am trying to figure out what has been done for WebGL that was not for Canvas in order to this happenā€¦

If someone with more knowledge about the inner work of ContentScale I really would appreciate the help!


EDIT: I was just trying here and in Chrome for Android it gives the same error, the game simply crashesā€¦ I have tried with the template and it works good, not sure where the problem liesā€¦


Hi Pedro,

Did your game work well on IE 11 WebGL mode?
I got the message ā€œINVALID_OPERATION: vertexAttribPointer: Enum UNSIGNED_BYTE is not currently supportedā€ when I was running our testcases on IE 11 WebGL mode.

And I will test it on Chrome for Android, could you please show some codes to reproduce the problem? and what version is your chrome and android?

Best regards


Hi David, how re u doing?

In fact I could not. I am forcing Canvas for Windows 8 and IE11, as well for the Windows Phone building that I am trying to work with.

For the Android I have tested on Galaxy Nexus with 4.3 with Google Chrome 30.0.1599.92.

I have added the file main.js that we are using to load the game and setting the contentScaleFactor by 0.5.


OK, got it.

We have modified the design of multiple resolution resources for Canvas mode, because the original design is very bad for performance.

It means that the real size of texture equals half size of design resolution when we calls setContentScaleFactor(0.5).

Could you please show some screenshots to us?

Iā€™m sorry for my misunderstanding.




I donā€™t think is a only problem for Canvas. I have tried the game with Android Chrome in a GNexus and also got the same errorā€¦ The most problematic thing is that not even the loading screen appears. I usually just get stuck with a black screen forever.

Anyway I will try to get some SS to make it clearer.

Kind regards,