libcurl can't work on Android?

libcurl can't work on Android?
0.0 0


[version] 0.12.0

I use curl to connect a web link, like; The program works well on ios (both device and simulator works well).

But it can not work on android (both device and simulator can not work)

on andorid, the return code of the function curl_easy_perform is CURLE_COULDNT_CONNECT (int:7).

Then I tried to remove the line “” from AndroidManifest.xml,

the return code of the function curl_easy_perform changed to CURLE_COULDNT_RESOLVE_HOST (int 6).


Finally, I tried the test demo in 0.12.0 . It worked well on IOS (both device and simulator)

But on android, it still can work . The return code of curl_easy_perform is 6 (CURLE_COULDNT_RESOLVE_HOST).


BTW, I tried it on simulator and 2 android devices ;


sorry, the test demo on andorid still can not work.


There are some features that, even being on tests or part of the documentation, are still not working.

Apparently this is one of those :frowning:


Is this seriously an issue? This will really put a hold to the progress of my project. Can anyone else confirm if libcurl can or cannot be used with Android?


I got libcurl downloading an image on my android, so it works for me: cocos2d-x 0.12.0, and you need <uses-permission android:name="android.permission.INTERNET"/> in your manifest file.


right, you should add internet access permission in manifest file