libcocos2dx.jar missing libcocos2dx/gen missing


#1

Hi,
Im new in the cocos2d-x world and my language is spanish so… sorry in advance if im asking silly questions.

Im trying to set up my first android project, following the steps in this tutorial:
http://www.jesusbosch.com/2012/06/how-to-set-up-android-and-win32-cocos2d.html

Everything seems to work except that when i import my project to eclipse (and project libcocos2dx) in my project properties->libraries i have an error:
libcocos2dx.jar missing.
In project libcocos2dx i have the error: libcocos2dx/gen missing.

It seems that i missed some step in which .jars and some other stuff are generated but dont know which one.

Thanks


#2

I met the same problem too @@ do anyone know how to fix it !

it said “The container ‘Android Dependencies’ references non existing library ‘F:2dxProject\FrameWork\trunk\Test\cocos2dx\platform\android\java\bin\libcocos2dx.jar’”


#3

It’s simple, I think maybe you have solved this already. I just leave my answer here for someone else have the some issue.

Only thing you guys need to do is import cocos2dx android project into your eclipse and build it, then you can see a libcocos2dx.jar lies on the bin folder.

The cocos2dx android project folder : cocos2dx\platform\android\java\


#4

Another option sometimes is just to close and open again Eclipse.

In my case I had the 2 projects (mine and libcocos2dx) but still was getting the same error.

As I mentioned above, just closing & opening again Eclipse it got fixed.