Issues with loading a ccbi file with cocos2d-x

Issues with loading a ccbi file with cocos2d-x
0.0 0


Hi there,

I’m currently trying to port an existing app I worked on from cocos2d-iphone 2.1 using cocosbuilder v2.1 to cocos2d-x with cocosbuilder 3 alpha 5.

Originally I was planning to use the existing ccbi files that I used in the previous project but I ran into a warning saying the version between the ccb file and the ccbreader does not match which lead to an assert:

Cocos2d: WARNING! Incompatible ccbi file version (file: 3 reader: 5)
Assertion failed: (child != __null), function addChild, file /libs/cocos2dx/base_nodes/CCNode.cpp, line 612.

I then decided to create a scene in Cocosbuilder 3 alpha 5, and it was able to load the default scene that was generated when you create a new project i.e. the MainScene, which has a JS Controller. However, when I create a new simple interface with just sprite and a label to test it I run into an assert when it’s loaded. It fails both when I have it as a custom class or without.

Assertion failed: (ccNodeLoadersIterator != this->mCCNodeLoaders.end()), function getCCNodeLoader, file /libs/extensions/CCBReader/CCNodeLoaderLibrary.cpp, line 67.

I read that that assert means that I don’t have the CCB_RESOLVER glue to hooked up in my custom class, but I didn’t assign any member variable for it to map nor custom classes.

I was doing my best to follow some online tutorials and documentation and I’ve searched around and I haven’t found my answer.

Any help would be much appreciated.



Sorry, I think I sorted it out. I ended up create a new ccb project using Cocosbuilder 3 alpha 4 instead of alpha 5, and manually copied the ccbi files generated into xcode project and make sure I used “Create groups for any added folders” instead of “Create folder references for any added folder” when copying it over.


Thanks man. :slight_smile: