Integrate cocos2d-x 3.0 with eclipse

Integrate cocos2d-x 3.0 with eclipse
0.0 0


Hi all, I’m really newbie in cocos2d-x , and i really need your help.
I follow ramki1979’s post in , but my project still have many error like cocos2d::Application (Symbol ‘Application’ could not be resolved)

I set Paths and symbols> include > gnu c++ : D:\android-ndk-r9-windows-x86_64\android-ndk-r9\platforms\android-14\arch-arm\usr\include and E:\cocos2d-x-3.0rc0\cocos2d-x-3.0rc0
i also have classes folder (from my project generate source) and cocos2dx (from cocos2d-x root , like E:\cocos2d-x-3.0rc0\cocos2d-x-3.0rc0\cocos).

How to fix these?
Thanks for spent times to read and help me.
Also sorry for my bad english!


I have the same problems as you and have yet to get an answer. I’ve looked all over the place and found the same website you link and still have problems. I cannot find what include file I need from cocos to get rid of the unresolved inclusion errors.

Someone please help us!


in my case,i can run testcpp project in my phone , but i want auto complete code in eclipse, and still no luck.

win32 project open with visual studio have no error , may be code by visual studio then run then run android .


Mine works fine with visual studio as well. The android project in eclipse is where I have trouble


Hi, i run testcpp with error 0xC0000005: Access violation reading location 0x000001E8
in funtion bool GLView::initWithRect(const std::string& viewName, Rect rect, float frameZoomFactor) line glfwSetMouseButtonCallback(_mainWindow, GLFWEventHandler::onGLFWMouseCallBack);

Have you trouble with that?


finally because my system not support opengl:
‘MyGame.exe’ (Win32): Loaded ‘C:\Windows\SysWOW64\cfgmgr32.dll’. Cannot find or open the PDB file.
‘MyGame.exe’ (Win32): Loaded ‘C:\Windows\SysWOW64\devobj.dll’. Cannot find or open the PDB file.
‘MyGame.exe’ (Win32): Loaded ‘C:\Windows\SysWOW64\dwmapi.dll’. Cannot find or open the PDB file.
GLFWError #65542 Happen, WGL: The driver does not appear to support OpenGL


Any solution please?


Yes i have the same problem.
Help us please :frowning: .


Same problem:

GLFWError #65542 Happen, WGL: The driver does not appear to support OpenGL

Visual Studio C++ Express 2012 and Windows 7. Fresh grab of the cocos2d-x source. Building test-cpp and get this error, but before this I was trying to run my app directly that I created as .exe in Release and Debug … Debug was launching it but manually opening the exe’s error’d out for both Debug and Release. I tried to change values and copy the Resources over but no luck… Would really appreciate any help on this looks like others are having this same issue.

When I redownloaded and tried to run test-cpp this is the error I got… so i’m not sure if these issues are all linked or what but I got a few things going on and at this point have no idea how to resolve them :frowning: