0.0 0


Im new to this. Back in version .4, i have triee installing it in atleast 3 different ways trying to follow different guides since each method didnt work for me or i just didnt understand very well the instructions.
I hope sum1 would be able to help me now.
What should i do next after unzipping the files to a certain folder?


which OS do yo have ?


Oh yeah i forgot 2 mention. Sorrry boutthat. Its windows7


ok simple ,
you download windows visual studio express 2012 ( its free )
now you have 2 options

  1. run the build-win32.bat from CMD
  2. load the cocos2d-win32.vc2012.sln file into VC


now to create new project use cocos2d-x-2.1.5\tools\project-creator\

or what i do :
load the cocos2d-win32.vc2012.sln compile , and then open new projects in the solution


Thnx. I tried the 1st suggesstion bfore. I wasnt able to install successfully the visual studio 2012. Besides, the guide i followed that time says to install 2010. So i tries 2012, i failed to install it. So i used 2010 which his guide suggested. And i was able to install it but didnt know how to proceed forward. Then after runnng the bat file, i recievee an error. I will try again to install 2012. But is it ok if it is just 2010? And 2nd question, regarding the 2nd option u mentioned… how would i actually load it. Sorry newb here. Sorry late reply, got busy. Thanks again.

  1. thanks. i believe i have installed both of them successfully. had i rough time since i had a bluescreen few days ago. Question:
    1. after unzipping the 2.1.5 version. i ran cmd, went to the path where it was extracted, then typed build-win32.bat . an error appeared

check vc++ environment…
building cocos2d-x library binary, please wait a while…

‘“”’ is not recognized as an internal or external command,
operable program or batch file.
( was unexpected at this time.

so i followed 2nd suggestion. i double clicked cocos2d-win32.vc2012.sln . and it appears it loaded cocos2dx with VS2012.

so the question would be. did i install it correctly? why did i receive an error when i followed the 1st option(cmd)? cpz that was the same error i had when trying it install 2.1.4 using cmd as well.

  1. 2nd question. it was mentioned to create new file, to use cocos2d-x-2.1.5\tools\project-creator\ . but how do i use it? double click? coz it is asking to choose which program after that. and if i choose Microsoft Visual Studio Version Selector, VS opens up and the Code appears. while the 2nd suggestion, again just to double click cocos2d-win32.vc2012.sln appears to load up cocos2dx with VS . it appears to me that these two methods shows different results.

have i set everything up correctly? are all of these expected? thanks again

PS. i am new to the environment of visual studio.