installing on MAC OSX Lion

installing on MAC OSX Lion
0.0 0


hi, i’m new to cocos2d-x, i’d like to develop under macosx lion.
my pc is a desktop pc i5 quad core and
in system requirements i have seen:
this: Supported Operating Systems: Mac OS X 10.5.8 or later (x86 only)
i don’t know if my pc is x86 or not, (i suppose is x64) how to know?
there is a way to develop with this machine?
it is sufficient to download Eclipse 3.6 (Helios) 32bit and install on a 64bit machine?

jdk must be 5 or 6, now there is jdk7 as latest version, if i go:
in the list of available os there is no mac, but solaris, linux, windows…
what should i download?