How To Build TestCpp for Android under OSX


#1

Sorry for the newbie question, but how do you get TestCPP for build for Android under OSX 10.8?

I have installed

  • Kepler Eclipse, C*+ Developer Tools, the lastest Android SDK, and NDK 8e.
  • cocos2d-x-2.1.4
    I tried
  1. copying TestCpp into my Eclipse workspace folder
  2. New / Project / C/C*+ / Makefile Project with Existing Code.

The result was that my project “TestCpp” showed up in the Package Explorer but I don’t see how to compile it. The source is also littered with errors such as

Method ‘release’ could not be resolved

FWIW, I tried building with project.android/build_native.sh but I got

Pauls-Mac-mini:proj.android paul$ ./build_native.sh
NDK_ROOT = /Users/paul/tools/android-ndk-r8e
COCOS2DX_ROOT = /Users/paul/projects/workspace/TestCpp/proj.android/…/…/…/…
APP_ROOT = /Users/paul/projects/workspace/TestCpp/proj.android/…
APP_ANDROID_ROOT = /Users/paul/projects/workspace/TestCpp/proj.android
Using prebuilt externals
/Users/paul/tools/android-ndk-r8e/build/core/add-application.mk:128: Android NDK: WARNING: APP_PLATFORM android-9 is larger than android:minSdkVersion 8 in ./AndroidManifest.xml
Android NDK: WARNING: Ignoring unknown import directory: /Users/paul/projects/workspace/TestCpp/proj.android/…/…/…/…/cocos2dx/platform/third_party/android/prebuilt
Android NDK: jni/Android.mk: Cannot find module with tag ‘samples/Cpp/TestCpp’ in import path
Android NDK: Are you sure your NDK_MODULE_PATH variable is properly defined ?
Android NDK: The following directories were searched:
Android NDK:
jni/Android.mk:22: * Android NDK: Aborting. . Stop.
Pauls-Mac-mini:proj.android paul$ set NDK_MODULE_PATH