Help! Instruments/Leaks doesn't work as expected !

Help! Instruments/Leaks doesn't work as expected !
0.0 0


Hey guys,

I’m sorry it’s a bit off topic but I’m running into a weird issue with Instrument/Leaks. I’ce spent hours on Google trying to fix it without luck so I give a try here.
Basically, I’m developing an app with cocos2d-x, and I’ve created a leak on purpose somewhere in my code just to make sure I would be able to track them during the dev process.
However, when I run the project in XCode with the “Profiling” scheme, it detects the leak but it doesn’t show where in the code, which makes it practically unusable.
I’m running the application on the Simulator, not on an actual device as I don’t have one at the moment.

I tried to play with the settings, but without luck:
* re-symbolicate the application, didn’t work.
* running the profiling with all debug options (editable in the scheme editor), didn’t work.

My Instruments looks like this:

If anyone can explain to me how to fix this problem, it would be great. Maybe it’s not possible to detect memory leaks in the simulator, but I didn’t see anything in that sense in the documentation.


leaks.png (178.0 KB)


Try opening the right sidebar. Also, when you hover over the items in the bottom area there is a little arrow button. Click on that to get more details.



Yeah, I’ve tried this as well. And it’s blank :

Do you confirm you are able to track leaks in the simulator with link to the source (i.e. backtrace working) ?


Click the arrow to get more details and the sidebar will display the code.


Sorry about the image attachments, they don’t work. The arrow I am talking about should appear when you hover over the objects.


Hey, thanks for your answers.

However, I don’t have any arrows showing when hovering.


Did you attach instruments through xcode? Try double clicking the items.


Ok I reinstalled OSX and everything runs fine now …

I must have corrupted my system somehow.

Thanks for your help anyway.