Fatal signal 4 (SIGILL) at 0x5b9a85d4 (code=1)

Fatal signal 4 (SIGILL) at 0x5b9a85d4 (code=1)
0.0 0


i finish a game by cocos2d-x 2.0.4. and now i port it to the android. it runs normal in the Android 2.3. but when i run the game in the Android 4.0 above, it crash by Fatal signal 4 at 0x5b9a85d4 * orFatal signal 11 (SIGSEGV) at 0x00000000 (code=1)*


12-03 11:16:22.398: D/libEGL(11957): loaded /system/lib/egl/libGLES_android.so
12-03 11:16:22.452: D/libEGL(11957): loaded /system/lib/egl/libEGL_POWERVR_SGX530_125.so
12-03 11:16:22.476: D/libEGL(11957): loaded /system/lib/egl/libGLESv1_CM_POWERVR_SGX530_125.so
12-03 11:16:22.515: D/libEGL(11957): loaded /system/lib/egl/libGLESv2_POWERVR_SGX530_125.so
12-03 11:16:24.405: A/libc(11957): Fatal signal 11 (SIGSEGV) at 0x356465c8 (code=1)

I need help with you


i run the game normal in the telephone of HUAWEI , Android 2.3.3 and Android 4.0.3 system, but failed in Motorola Android 2.3.3 and Android 4.0.1, and also succeed in HTC, Android 2.3.3


i had solved this problem,
my png pictures is 2048*4096 ,and the Motorola can’t support more than this size , so i cut the picture to two more little pictures, and it works well!:slight_smile: