[fatal signal 11 sigsegv at 0x00000000]: My problem solved

[fatal signal 11 sigsegv at 0x00000000]: My problem solved
0.0 0


So I got this stupid “fatal signal 11 sigsegv at 0x00000000” error randomly one day. But it wasn’t random as I thought.

In Eclipse Android.mk file, I erased
LOCAL_SRC_FILES := hellocpp/main.cpp \

“hellocpp/main.cpp” because I thought this line is not essential, but it is. If you go in to that folder and open up main.cpp, it does something for you. I dont’ know what exactly this file does, but it must be something that starts application…

I’m writing this here because I saw other people who have the same problem as me when I was searching for an answer, but I couldn’t resolve my problem from any of the answers I saw (May be they had different problem?)/

I haven’t learned many things in programming but here you go. If you have the same problem as mine in eclipse using cocos2dx, this could be your solution.

and…does anyone what that main.cpp file does? Can you please tell me (doesn’t have to be very detailed)? Just Curious


Yep, I met the same issue and your solution solve it! :wink: