Error Creating Android Project Windows

Error Creating Android Project Windows
0.0 0


I create an android project via create-android-project.bat but I do get this :

Please input target id:15
Create android project
Create Android project inside
Created project directory: D:2d-x\Cococs2dTest\
Created directory D:2d-x\Cococs2dTest\\src\com\cocos2dxtest
Added file D:2d-x\Cococs2dTest\\src\com\cocos2dxtest\
Created directory D:2d-x\Cococs2dTest\\res
Created directory D:2d-x\Cococs2dTest\\bin
Created directory D:2d-x\Cococs2dTest\\libs
Created directory D:2d-x\Cococs2dTest\\res\values
Added file D:2d-x\Cococs2dTest\\res\values\strings.xml
Created directory D:2d-x\Cococs2dTest\\res\layout
Added file D:2d-x\Cococs2dTest\\res\layout\main.xml
Added file D:2d-x\Cococs2dTest\\AndroidManifest.xml
Added file D:2d-x\Cococs2dTest\\build.xml
Added file D:2d-x\Cococs2dTest\\proguard-project.txt
sed: can’t read /cygdrive/d/Development/cocos2d-x/Cococs2dTest/ Permission denied
rm: cannot remove `/cygdrive/d/Development/cocos2d-x/Cococs2dTest/’: Permission denied

I also notice that the org.cocos2d-x.lib and org.cocos2d-x.helloccp is empty :*

Logcat Error :


I have faced similar problems before make sure that you put cocos2d-x in a FAT file system as NTFS has some problems with cocos2d-x and also no spaces should be present between the folder names of NDK,SDK and cocos2d .


I am also facing same error!

…/ Permi
ssion denied
Press any key to continue . . .

-No space in any file names.
Any solution…???


I have exactly same problem? Does nobody know solution?


I have the same problem before I had change my computer…
And I think you may try to use the Administrator account to login your computer(win 7).
It may change something…


I had the same problem! Just go to the cocos2d-x folder settings and give all permisions to all users for all included folders. If to say easly just give to the folder and all includers 777 rights.


I have given full permission to all folders but still the same error…

…/ Permi
ssion denied
Press any key to continue . . .


chmod 777 -R *
while youre in the folder. that gives all permissions to each folder and subfolder plus files inside.


permission issue solved.
solutions I followed:
1)go to start menu and open cmd as administrator
2)navigate to create-android-project.bat and run
3)same for cyg terminal(go to start menu open cyg terminal as administrator)
4)if again any permission denied issue for any file/folder is found :
**open the properties of that file/folder
**in general tab, clear read only checkbox
**in security tab, press edit button and set full control checkbox for all users.
**then try again(1 or 3 step).