Effekseer - Particle effect editor for Cocos2d-x

Effekseer - Particle effect editor for Cocos2d-x


Thank you or running it. I found that this particle is for PC so it is slow on a mobile environment.
I plan to change a sample particle for a mobile environment.


I integrated Effekseer into my project to try it out.
There is one major problem with the cocos2d-x integration - rendering seem to completely ignore parent transformations. What I mean is: when I add an effect as child to some cocos2d::Node and move that node, the effect doesn’t move. Other then that, looks really good :slight_smile:


I played demo on cocos2d-x, this only view as 2D, how can i show it in 3D?


Thank you for integrating it.
I will try to fix it at New Year’s holiday (Sorry. I’m a bit busy)


I haven’t use cocos2d-x in 3D.
I try to use in 3D, after that I try to fix it at New Year’s holiday (Sorry. I’m a bit busy)


Can this particle editor/library be used with Cocos Creator?


Some more feedback from my side:
Tested on ipad2 and iPhone 4s and the performance is very bad. I know these are ancient devices but still :frowning:


Sorry for it cannot use it currently


We are improving it currently.
We supported NOEN in ARM.
So it perhaps improves a performance.


Awesome editor!!!
I have the same problem with “rendering seem to completely ignore parent transformations”
another problem is i use the Non-default camera. it is also wrong transformations.


We perhaps fixed this bug about parent transformations at leaset in the recent repository.
Please check it.
if this bug is not fixed, please tell me about the non-default camera.


thanks. the first problem is solved.
in cocos2dx, you can create another camera.

local camera = cc.Camera:createPerspective(30, MAX_SCREEN_WIDTH / MAX_SCREEN_HEIGHT, 1, 100000)

camera:setPosition3D(cc.vec3(90, 90, 0))



in this way, the transformations still wrong.
i think the m_camera and m_proj in class RendererImplemented needs to be recalculation.

the cameras in this function
void Scene::render(Renderer* renderer)


i try to fix it.
this is my changes.

effekseer.zip (123.7 KB)


Thank you. I will check it.


I fixed it


I hope you can solve the problem of mobile phone performance. thank you very much.

in iphone6s:
Homing_Laser01.efkproj fps:50
Simple_Distortion.efkpro fps:30
Sword_Ember.efkproj fps:20
in windows:
all fps 60.
in android:
i have not running on android. but i think it’s lower than iOS.

How about batch draw?

@slackmoehrle any ideas?


I don’t think particle effects auto-bath. I would need to ask an engineer for thoughts.


After my experiment.
I think this is rendering performance bottlenecks.


I’ll check it.
Sword_Ember.efkproj is very heavy and not for smartphones.
But others feels strange.


By the way, i enable the distortion.