create-android-project problem

create-android-project problem
0.0 0


I try to use create-android-project to create helloworld but it didn’t work.
I have set the cygwin, android sdk and ndk path properly in create-android-project.bat.

Pls see the attachment file for the compile summary.

Thank you.

android.png (396.5 KB)


I did not see any error in the attached file, you can try launching the command prompt as an administrator and try running create-android-project.bat through cmd.


What’s the problem?
It looks like it created the project as you requested.

Have you tried importing that project in to eclipse?

What about the, what happens when you run that?

As you are using windows, I found the best was was to create a build.bat that just runs the correct cygwin command.
Then you can just tell eclipse to run that build.bat in the project properties.


After run build_native, the template compile successfully.
But I found that the Appdelegate.cpp…. file not in jni folder. I can browse the Appdelegate.cpp in Class folder. I cannot see it at Eclipse.

When load in eclipse, got tons of errorssssss. So far, the error left is android-sdk/platforms/android-15/android.jar has no source attachment after clicking debug(same error with android-sdk/platforms/android-17/android.jar)
I have tried using eclipse and ADT. (after I solved 1 error another error(or other errors) come up, the error is non-stop, it is terrible to create the android template, I have taken 1 week to troubleshoot it)


Have you read the tutorials on

Its a good place to start.


Instead of using the shell script, I find it easier to just copy and paste the HelloCpp sample project and start from there.

See this under New iOS Project via Copying