create-android-project creates the HelloWorld example instead of my Pong

create-android-project creates the HelloWorld example instead of my Pong
0.0 0


after searching and testing for a few days and finding nothing in the forums I’m going to have to ask for a little help to get my project working.

I’m doing a project under Win 7 using cocos2d-1.0.1-x-0.9.1 and NDK r6b. I downloaded the cocos2dx files, ndk and Cygwin, set it up and modified the paths as instructed in the tutorial. I created the helloworld project and it worked in win32 and android.
After that, I created a test game, a Pong clone, to explore the library a bit more in depth. It works fine in win32, but when I try and create the android project using the create-android-project.bat, for some reason I end up with a folder that has the “HelloWorld” files instead of my “Pong” files.

# Create a Cocos2d win32 application project in Visual Studio, in the D drive (D:2dxTest\Pong)
# Modify the project in visual studio to include the library folder, link the .libs and add the .dll to the output folders.
# Program the Pong game in this application
# Test in win32 and see the Pong working.
# Copy the Pong folder to the cocos2dx root (C:2d-1.0.1-x-0.9.1\cocos2d-1.0.1-x-0.9.1\Pong)
# Fire up the create-android-project.bat (preciously modified to change the paths to Cygwin, NDK and SDK tools)
# Set as path: org.cocos2dx.Pong
# Set as name: Pong
# Set as version the id corresponding with android 2.3.3
# This creates an android folder inside the Pong folder I copied to the cocos2dx root (this folder looks suspicious in the sense that it has in the Resources folder the resources for the HelloWorld example, not the gfx I created for the Pong game)
# Fire up Cgywin, navigate to the cygdrive/C:2d-1.0.1-x-0.9.1\cocos2d-1.0.1-x-0.9.1\Pong
# Call ./ and have it compile
# Create a new android project in eclipse and select the C:2d-1.0.1-x-0.9.1\cocos2d-1.0.1-x-0.9.1\Pong\android folder as the location of the project
# Hit “run” in eclipse and find myself looking at the helloworld example, instead of the Pong game.

Thinking I might have messed something up, i erased cocos2dx and cygwin and downloaded everything again, but I get the same result.

Help would be much appreciated, ask for any extra info you might need to figure out the issue.
Thanks again!


Yeap, the template creates android project based on HelloWorld. And I don’t modify the folder name, it is also called helloworld. Because it has more work to do with it. You can ignore the folder name.

The project created by create-android-project.bat is just a start point of your android project. You can replace Resources folder and Class folder with your project.


Thank you for your reply. I created an expanded tutorial for the android configuration part in case anyone else gets stumped.
I leave it here .