compile error in cocos2d-2.1rc0-x-2.1.2

compile error in cocos2d-2.1rc0-x-2.1.2
0.0 0



i have downloaded cocos2d-2.1rc0-x-2.1.2. it’s cool. especially project-creator is awesome.
but i got trouble for iOS.
building on win32 and android is perfect. but building on iOS is failed.
when i try to build HelloCpp.xcodeproj, i get error like this:

/Applications/ -dynamic not specified the following flags are invalid: -ObjC 
/Applications/ can't locate file for: -lwebp
/Applications/ file: -lwebp is not an object file (not allowed in a library)
Command /Applications/ failed with exit code 1

I had guessed it’s linking directory problem. but project’s “libray search path” set “$(SRCROOT)/…/platform/third_party/ios/libraries” well. is it not enough?
I have no idea about this. Xcode and MAC is unfamiliar surroundings for me. T_T
Plz give me a clue


oh shit…. what have i done ?!?
it’s my mistake. i had delete webp’s libray file.
i’m fooooooooooooooooooooooooooooooooooooooooool :stuck_out_tongue:


Got the same problem.

Can’t remember that I deleted webp library.

Is that a pre-installed OSX lib?
Or does Cocos2d-x build this?


Yep, it is a prebuilt static library.


@Minggo Yes. I saw it it’s part of the Cocos2d-x framework. The iOS Sample “TestCpp” will not build even the libwebp.a is part of the build process. The templates works


I had the same issue. My fault was not to change the svn settings. i used windows to check in the new version of cocos2dx. per default svn ignores all *.a files. thats the reason it was not available on my mac.


much appreciate for the help from Andreas Mank. i met the same problem and solved it by change the default setting of SVN


oh useful information


Right path for ‘Library Search Paths’ in ‘Build Settings’ for TestCpp project in Samples: