CocoStudio on Mac OS X

CocoStudio on Mac OS X
0.0 0



I am not sure if there is any plan to port CocoStudio to Mac OS X. However, I was thinking to run the tool on top of a Virtual Machine with Windows 7 as guest. Does anyone have experience on this topic?

I tried to do it using VirtualBoax, but the tool does not run. I see that there is an instance at the Task Manager and that’s all. I tried also to enable the 2D and 3D acceleration. However, still the same problem

I appreciate if anyone can comment on this topic



I have the same setup, VirtualBox and Windows 7… just shows the main menu…


I managed to open the Data Cruncher, but it’s not working. Where can I find the code of CocoStudio. Maybe I can run it through VS


Hi Gizmo,

I have the same problem.
in my VB setup I have 2 cpus and 4gb of memory ram, 128 mb video,
last cocos2d-x installed, .net 4.5, VS 2012, NDK 9c,…
But doesn’t work.

Only works in a real machine :frowning:



I’m using VMware Fusion, and it’s good…

Try to activated the hardware virtualization…It may work…


Hi, it works with VMware. Thanks a lot!!! (/)


True, it works, but not in win 7 64 bits, only in 32 bits.



@zijian.rao , @GiZmo , @ others pls help,
Cocostudio Animation Editor crashed :frowning:

I’m running win 8 64 bit on VMWare Fusion / Mac OS X.
I have alloted 2 cpu cores ( out of 4) and 2GB RAM ( out of 4GB) for win 8 on vm ware.

I installed Cocostudio with all the mentioned pre requisites .NET Framework , VS 2012 etc
But of the four editors, only Data Editor is opening. UI Editor & Scene Editor crash silently.

Animation Editor crashes with an error report (snap attached below). Is there a fix for this?
Should I uninstall Cocostudio and reinstall older stable version?
Or is this due to virtualisation settings :confused:

Should I try cocostudio on win 7 32 bit or does it work on win 8 64 bit? :frowning:


I am using Windows 7 32bits and it works like a charm. Try to change configuration of the VM and check if that fix your issue


I tried installing cocostudio on Windows 7 32 bit and animation editor crashed with the same error message as on Win 8 64 bit.
What is the required configuration for VM Ware Fusion? The other programs are working fine. I am unable to figure if it is crashing due to .NET Framework based program or VM Ware Fusion configuration. I have added VT-X (hardware acceleration) in the .vmx file. Can you post what the ideal configuration file settings looks like?

If this doesn’t work, I may have to wait till May for Cocostudio Mac to be released. Till then I would have to make do with Spritebuilder with a C++ CCBReader (TBD). Meanwhile, shall try installing an older stable version of Cocostudio and report back here on the results.


Thanks @GiZmo & others,
It worked on win 8 32 bit after upgrading the openGL drivers of VMWare to SVGA.


Does anyone eventually manage to run CocoStudio on VirtualBox?
CocoStudio on Windows 7 32bits in VirtualBox running on MacOS does not seem to work.
I’ve installed all packages required by CocoStudio (.Net Framework, Visual C++ 2010/2012 Redistributable) and 3D acceleration (opengl/directx) has been installed from the virtualbox guest additions and enabled in the virtual box settings.
Any help is appreciated…


I already tried with VirtualBox and it does not work. WMWare Fusion with Windows 7 32bit was the only alternative that I found useful


@GiZmo Yep, indeed, I tested on VMWare Fusion and it works pretty well with Windows 7 32bit.
Hope next VirtualBox release will have better opengl support and we’ll be able to run CocoStudio.


v1.4.0.0 of CocoStudio works fine in Parallel as well.


The alpha version of CocoStudio on Mac OS X is just released. Download from

It uses mono to cross platform, and sync features with its windows version. It’s still an alpha version, but you can have a try.

Any reason for ignoring Linux tools?

That’s good news @walzer! I’m going to download and give it a try. Thanks!


Am I correct if I say that it includes only the UI Editor? Or are the other editors hidden somewhere?


I downloaded it on my mac but its in chinese, is there a way i can change this?



nevermind i fixed it